Swarm port configuration

Hi! I am successfully running a local swarm, but it changes client connection port every time the swarm is restarted.

This is what I get after running “libra_swarm -h”:

libra_swarm 0.1.0
Libra
Libra swarm to start local nodes

USAGE:
libra_swarm [FLAGS] [OPTIONS]

FLAGS:
-l, --enable_logging Enable logging
-h, --help Prints help information
-s, --start_client Start client
-V, --version Prints version information

OPTIONS:
-c, --config_dir <config_dir> Directory used by launch_swarm to output LibraNodes’ config files, logs,
libradb, etc, such that user can still inspect them after exit. If
unspecified, a temporary dir will be used and auto deleted.
-f, --faucet_key_path <faucet_key_path> If specified, load faucet key from this file. Otherwise generate new
keypair file.
-n, --num_nodes <num_nodes> Number of nodes to start (1 by default)

Is there any other swarm parameter to specify swarm port?

Thx! :+1:

1 Like