Mint fail for clients connected to local validator node

Tried to setup local validator node in a cloud server with firewall. Got the localhost:port after successfully bringing node up. After setting firewall rule for that port, laptop libra client could connect to it. But account mint or query failed.

libra% account mint 0 100

Minting coins
[ERROR] Error minting coins: invalid digit found in string

The same cmd could complete on the server side. Did I miss any other ports on firewall setting or anything else should be done?

@ylv

Which port number were you using? Also, which CSP are you using? I threw together something on GitHub for this on AWS, but it would not be too different running on GCP (I am planning that one too) - it is here: https://github.com/jonrau1/AWS-Libra-Blockchain

You need the admission control service port, as well as the faucet keypair that you pass when you start your remote clients. The port that is given is the Execution Port when you start up Swarm IIRC

Great article! Faucet keypair is the problem in my case.