Local Validator Node

there is error occurred here :
cargo run -p libra_swarm – -s

Faucet account created in file “/tmp/keypair.Raw0aKx8y6NC/temp_faucet_keys”
Base directory containing logs and configs: “/tmp/.tmpLWM5DV”
thread ‘main’ panicked at ’
Unable to build all workspace binaries. Cannot continue running tests.

Try running 'cargo build --all --bins' yourself.

', libra_swarm/src/utils.rs:31:13
note: Run with RUST_BACKTRACE=1 environment variable to display a backtrace.

any help?

1 Like

Can you run cargo build --all --bins and paste details of your issue here?

— stderr
CMake Warning at CMakeLists.txt:79 (find_package):
By not providing “Findgflags.cmake” in CMAKE_MODULE_PATH this project has
asked CMake to find a package configuration file provided by “gflags”, but
CMake did not find one.

Could not find a package configuration file provided by “gflags” with any
of the following names:

gflagsConfig.cmake
gflags-config.cmake

Add the installation prefix of “gflags” to CMAKE_PREFIX_PATH or set
“gflags_DIR” to a directory containing one of the above files. If “gflags”
provides a separate development package or SDK, be sure it has been
installed.

CMake Error at /usr/share/cmake-3.5/Modules/FindPackageHandleStandardArgs.cmake:148 (message):
Could NOT find zlib (missing: ZLIB_LIBRARIES)
Call Stack (most recent call first):
/usr/share/cmake-3.5/Modules/FindPackageHandleStandardArgs.cmake:388 (_FPHSA_FAILURE_MESSAGE)
cmake/modules/Findzlib.cmake:17 (find_package_handle_standard_args)
CMakeLists.txt:95 (find_package)

thread ‘main’ panicked at ’
command did not execute successfully, got: exit code: 1

build script failed, must exit now’, /basel/.cargo/registry/src/github.com-1ecc6299db9ec823/cmake-0.1.40/s rc/lib.rs:832:5
note: Run with RUST_BACKTRACE=1 environment variable to display a backtrace.

warning: build failed, waiting for other jobs to finish…

what operation system do you use?
did you run scripts/dev_setup.sh successfully?

Ubuntu 16.04, yes it was successfully and i tested the same server for testnet after that i decided to test the local node .

Could you run cmake --version to check the version?

this is output
cmake version 3.5.1

Could you try to run sudo apt-get install cmake to update it?

cmake is already the newest version (3.5.1-1ubuntu3).

try downloading cmake 3.14 and tar xvf

I got the same error message (Could not find zlib) and solved it by reinstalling zlib with the command “sudo apt-get install zlib1g-dev

from my side, runing an unbuntu 16 machine on aws c9 i get always

error: Permission denied (os error 13) on everything with cargo command.

I’ve scripts/dev_setup.sh with success and CLI client is OK but running anything with cargo gives an error

Looks like you need root access to compile binaries.

Did you try to use chmod on your directory to allow modifications ?

Hello there @CryptoMarabout and @yehors

Thanks for the input

So good news, i’ve managed (after lots of trial-error-trial-error-trial-error-trial-error-success, weekend fun!) to build the local node on aws + CLI attached and play with my testnet with original modules (transfer/mint).

But, i’ve only managed to install/compile/run on a sudo su user, so when i close terminal is like “nothing is saved” and it recompiles (20min on a t2.medium 8gb ram machine) at each new playing session.

Any advice to compile it just once ? I guess its a user management problem, but im not expert at all at linux+aws+libra, hence the trial-error-trial-error-trial-error-trial-error-success :sweat_smile:

1 Like

yum install zlib-devel