How to specify API port for libra swarm

Hi All,

Do you know how I can specify the port in the config file(s) for the libra swarm’s libra API?

I have placed the config files but each time I restart the libra-swarm the port is random:

/path/to/config/0/node.config.toml

To run the Libra CLI client in a separate process and connect to the validator nodes you just spawned, use this command:
cargo run --bin cli – -u http://localhost:37047 -m “/home/sb_mainu/libra-config/mint.key” --waypoint 0:123456789123456789

How could I specify 37047 port in my config file or somewhere else?

Same for the waypoint. It also changes!

Thank you in advance

@dtakis Check out this doc page here: https://developers.libra.org/docs/reference/libra-cli

Hi, if I try to define a port
e.g. cargo run -p 37047 libra-swarm – -s -n 4 -l -c /home/user/libra-config/

I get this error:

error: package 37047 is not a member of the workspace

Which points to the fact that the -p parameter is unrelated!